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A Guide to Using CLion

August 25, 2019

1 CLion

CLion is a comprehensive C++ Integrated Development Environment (IDE) developed and main-
tained by JetBrains. It is very intuitive and easy to use. For this class, we will use CLion for all of
our work.

1.1 Applying for a Student License

In order to use CLion, you need to apply for a license. Go to https://www.jetbrains.com. From
the menu on the top of the screen, choose Support and then Education. You should see the

following screen:
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Community Programs « 1 Open Source

Free Educational Licenses

Are you a student or an academic staff member?

Classroom Licenses for Accredited Educational Institutions

We provide free licenses to universities, colleges, schools and other non-commercial educational organizafiil
support classroom instruction in on-site classrooms and computer labs.

Figure 1: Applying for a Student License

Click on the ”APPLY FOR FREE STUDENT PACK” button.

You will then see a page that gives you all the details for a Student License, You can read through
them if you like, Then click on the blue ”APPLY NOW?” button. You should now see the following

screen:


https://www.jetbrains.com

JET
BRAINS

JetBrains Products for Learning

Apply with: UNIVERSITY EMAIL ADDRESS 1SIC/ITIC MEMBERSHIP OFFICIAL DOCUMENT GITHUB
Status ®) I'm a student

I'm a teacher
Name:

Our software will be registered to your real name

Email address:

Country / region: United States

I am under 13 years old
| have read and | accept the JetBrains Account Agreement

| consent to the use of my names, email address, and location data in email communication
concerning JetBrains products held or services used by me or my company More

APPLY FOR FREE PRODUCTS

Figure 2: Applying for a Student License

Please provide an FSU email. You will get a reply from JetBrains in a few minutes, asking you to
confirm the request for a student license.

Once you confirm the request, they will send you another email, asking you to create a JetBrains

Student Account. This takes about 5 minutes. Once you create the account, you should see a page
with your Key.

2 Installing CLion

You can now download and install CLion. Download CLion from https://www. jetbrains.com/
clion/download. The page will automatically show you the right installer for your Operating
System. Download the installer.

2.1 For Macs/Linux Machines

If you have a Mac or a Linux Machine, you already have a lot of the prerequisite programs needed
for CLion. All you need to do is a couple of simple steps.


https://www.jetbrains.com/clion/download
https://www.jetbrains.com/clion/download

2.1.1 Mac OSX
Once you have downloaded the dmg file, use Finder to open the Applications folder. Move the file

you just downloaded from the Downloads folder into the Applications folder. You're all set. Move
on to Section 3.

2.1.2 Linux Machines

Download the tar from the website. Unpack it and then navigate to the bin directory and run
CLion.sh. Once this is done, move on to Section 3.

2.2 For Windows Machines

Download the installer from the website and run it. It will start up the installation wizard.

@ CLion Setup

Welcome to CLion Setup

Setup will guide you through the installation of CLion.
It is recommended that you close all other applications before
starting Setup. This will make it possible to update relevant
system files without having to reboot your computer.

Click Next to continue.

Next > Cancel

Figure 3: Installation Wizard

It will now ask you to activate your CLion License. Put in the Username and Password for the
JetBrains account you created. Click on Activate

& Clion License Activation = O X

®Activate  OEvaluate for free Buy CLion

Activate license with:

®JetBrains Account  OActivation code  OLicense server

Username or email:

Password: Forgot?

Activate Exit

Figure 4: Activate your license

Click on Next. It will ask you to choose a location to install CLion. Go with the default option.



|82 CLion Setup - X
I Choose Install Location
Choose the folder in which to install CLion.

Setup will install CLion in the following folder. To install in a different folder, click Browse and
select another folder. Click Next to continue.

Destination Folder

[C:\Program Files\JetBrains\CLion 2019.2.1] Browse...

Space required: 1.2 GB
Space available: 57.9 GB

Figure 5: Installation Location

Click on Next. It will ask you to choose file associations. Check all the boxes.

B Clion Setup - X
Installation Options
Configure your Clion installation
c
Create Desktop Shortcut Update PATH variable (restart needed)
64-bit launcher [ Add launchers dir to the PATH

Update context menu

Add "Open Folder as Project”

Create Associations

Me Mh Mc Meop Mox [Mhp [Mhxx

< Back Cancel

Figure 6: Choosing File Associations

Click on Next. It will ask you to choose a Start Menu Folder. Go with the Default option, which is
“JetBrains”. This will create an entry for JetBrains and then CLion on the Windows Start Menu.

] clion Setup - X
Choose Start Menu Folder
Choose a Start Menu folder for the Clion shortcuts.

Select the Start Menu folder in which you would like to create the program'’s shortcuts. You can
also enter a name to create a new folder.

7-Zip
Accessibility
Accessories
Administrative Tools
Maintenance

Microsoft Office 2016 Tools
Microsoft Office Tools
Notepad++

Oracle VM VirtualBox
StartUp
System Tools
Tectia Client
\ind,

bl v

<back Cance

Figure 7: Choosing File Associations



Now click on Install. This will complete the setup. It will ask if you want to run CLion. Say Yes.

3 Running CLion for the first time

Once you have installed CLion, you can run it. There is a bit of setup to do when we run CLion
for the very first time. This is mostly the same on all platforms. For Windows, there is an extra
setup to get a Unix based C++ compiler installed, but the CLion Wizard will guide you through
it.

When we first run CLion, it will ask if we would like to import settings. You will see the fol-
lowing dialog box.

| gh“rm" CLion Settings Fromn
I O Previous version

: O Config or installation folder:
|

| @ Do not import settings

Figure 8: Importing Setting
Choose “Do Not Import Settings”. Click OK. It will ask you to accept the User Agreement. Read

through the user agreement, if you desire to do so, and then check the box confirming that you
Agree. Click on “Continue”.

It will ask if you would like to send usage statistics to JetBrains. Choose whichever option
(Send/Don’t Send) that you are comfortable with.

It will ask you to choose a theme. Pick one that you like.

Figure 9: Choose a Theme

Click on Next: Toolchains. This is where the paths diverge for Mac and Windows machines.



3.1 For Macs / Linux Machines

Macs and Linux Machines most likely already have working installations of the C++ compiler, the
make utility and a version of the GDB debugger. CLion should be able to automatically detect
these. You should see a screen that looks like this, with different numbers next to CMake and GDB:

@ ) Build, 1 » Toolch
Appearance & Behavior
Menus and Toolbars

CMake executable:

System Settings © Bundled CMake 3.8.2
File Colers [
O Custom: ‘D
Scopes ®
Notifications
Quick Lists Debugger:
Path Variables © Bundled GDB7.11.1
Keymap
Editor O Custom GDB: ‘D
Plugins
Version Control ® O Bundled LLDB 3.9.0

Build, Execution, Deployment

v cmake: 382

CMake @  make: fusr/bin/make
Debugger ¢ Compiler: fus/binfcc
Python Debugger -  C++ Compiler: fusr/binfc++
Python Interpreter & YRR

Deployment [

Console B

Languages & Frameworks
Tools

BED [ cercel] [ #eply | [ Heb |

Figure 10: Toolchains

Click on OK. Your setup is now complete.

3.2 For Windows Machines

Windows machines do not come with an installation of the required programs, so you should see a
screen that looks like this:

& customize Clion X
Ul Themes — Toolchains — Default plugins — Featured plugins

Configure Toolchains

+ -0+ 3

No toolchains configured

No toolchains You can add MinGW or Cygwin toolchain

Toolchains can be changed later in Settings | Build, Execution, Deployment | Toolchains

Skip Remaining and Set Defaults Back to Ul Themes. Next Default plugins

Figure 11: Toolchains



Click on the link that says Cygwin. You should now see this:

Click on Download. It will open the following screen on your web browser.

click on “setup-x86-64.exe”. This will download the installer

Admin privileges.

Configure
+ -0
cyouin

Toolchains can

Toolchains — Default plugins — Featured plugins

Toolchains

be changed laterin Settings | Build, Execution, Deployment | Toolchains

Skip Remaining and Set Defaults || Back to Ul Themes Next Default plugins.

Figure 12: Toolchains

Figure 13: Installing Cygwin

(€ cygwin Setup. - a X

Cygwin Net Release Setup Program

This setup program s used forthe ntilinstaltion of the.

Cygwin environmert s wel a5 o subsequent updates. Make

Sure o remember where you saved

The pages thatfolow il guide you through the instaltion.
2 wide v oses iy

instal ou ays n

this program at any tme i the fuureto add, rem

pgade packages as necessay.

Setup version 2.897 (64 bit)
Copyight 9

Figure 14: Installing Cygwin

. Run the installer

. This might require

e It will ask you for installation options. Choose “Install from the Internet”. Then click on

Next.

e It will ask you to choose a directory for installation. Go with the default option (something
like C:\cygwin64). It will also ask you to choose users. Choose “All Uses”. Click on Next

e It will ask you where to store the Downloaded files. Go with the default option (most likely
your Downloads folder). Click on Next.



e On the next screen, choose “Use System Proxy Settings”. Click on Next.
e The next screen will show you a list of “mirrors”. You can pick any of them. Click on Next.

It will ask you to choose which packages to install. To keep things simple, we’re going to install the
6 required packages for C++. You should be seeing the following screen.

(E Cygwin Setup - Select Packages - o X
Select Packages
Seecpaasto o c
View [Pendng  v| Search| Cear Okeep @Best  OSme  [Test
= Curert Tew Bn? Sc? Categores I
GeolP dasbase 27 201805051 ST [ e e
GraphicsMagick 132781 13331 < ] [ Geashics
GraphicsMagick debuginfo 132781 13331 ~|[4] [ oebug 3
Inageagck 639113 6910111 < 7] [ Gashes
ImageMagick debugnfo 699113 6910111 ~| [7] [ oebug 5
inageMtagckdoc 699113 6310111 < 7] [ Geohes B
R 3431 3601 <[ @] [ Mah. Science 0
Rdebugrdo 3431 3601 <| & [] oebug 5
Texmacs 15521 15851 <@ [ edon P
TeXnacs debugrto 18921 19951 <| [ [ oebug 2
Windowhaker 0581 0582 <l@ O 1
WindowMaker debugifo 03581 03582 <& [ oebu 1
abiword 3022 3023 <| [ [ Edtors. Pubishing
‘abiword debugifo 3022 3023 ~| ¥ ] oebug 2
abiwordphogns 3022 3023 <| ] [ Edtors. Pubisting
adwataicontheme 3201 3% < [7] [ cnom 2
adwata contheme devel 32401 a1 < [F] [ cnome
akonad 11305 171231 - [F [ wee
| deorddeare 11305 171231 <1 1 oebwg BV
< >
[ Hide obsolete packages
<Back Cancel

Figure 15: Installing Cygwin

e Go to the Drop-down box on the top left (which probably says “Pending”) and choose “Full”.

e Search for gcc-core. You will see the following screen. Click on the drop down box on the line
for gee-core:. Choose a number like 7.4. Sometimes, you might get multiple version numbers.
Pick the latest (largest) version number that doesn’t say “Test”.

€ cygwin Setup - Select Packages - m} X
Select Packages
Select packages to install 3=
View | Full ~ | Search|gcccore Clear (OKeep @Best (OSync [Test
‘ Package Current New Bin? Src? Categories Size ‘
cygwin32-gcc-core 6.4.01 Keep j D D Devel 16,464k (|
digpp-gcc-core 5401 Keep LI I:‘ D Devel 7.926k (
6404 17401 M &[N D 18710k [
mingw64686-gcccore 6.4.01 Keep LI D D Devel 14,476k (|
mingw64x86_64-goc-core 5402 Keep ~0O O bews 14921k
< >
Hide obsolete packages
< Back Next > Cancel

Figure 16: Get gcc-core

e Clear the search bar. Search for gcc-g++. You will see the following screen. Click on the
drop down box on the line for gcc-g++. Choose a number like 7.4. Sometimes, you might get
multiple version numbers. Pick the latest (largest) version number that doesn’t say “Test”.



[E cygwin Setup - Select Packages - O X
Select Packages
Select packages to install b
View [Ful | Search [goog Clear Okesp @Best Omne  [OTest
Package Curment New Bin? Src? Categories Size |
cygwin32gocg++ 64.01 Keep ~[ ] T[T Devel 10,456k
djgpp-gcc-g++ 5401 Keep LI D D Devel 8.27% (
gocge+ 5402 74 | [ Devel 12118k (
mingw644686-goc-g++ 64.04 74041 ~| [] Devel 10,964
mingw64%86_64-goc-g++ 6402 7401 | 1 Devel 11347 ¢
< >
Hide obsolete packages
<Back Net> | | Cancel

Figure 17: Get gce-g++

e Clear the search bar. Search for libgcc. You will see the following screen. Click on the
drop down box on the line for libgccl. Choose a number like 7.4. Sometimes, you might get

multiple version numbers. Pick the latest (largest) version number.

€ cygwin Setup - Select Packages - O X
Select Packages
Select packages to install =
View | Full ~|  Search ibgce Clear (OKeep @Best (OSync [ Test
Package Current New Bin? Src? Categories Size |
libgcc 1 6404 7401 | [T s 2% (
lbgccpp 1 2041 | 1 bs * 0
< >
Hide obsolete packages
< Back Next > Cancel

Figure 18: Get libgcc

e Clear the search bar. Search for make. You will see the following screen. Click on the drop
down box on the line for cmake. Choose a number like 3.14.

e Scroll down a little bit until you see make. Click on the drop down box on this line and choose
a number like 4.2.1.



€ cygwin Setup - Select Packages - [m] X
Select Packages
Select packages to install >
View | Full ~ | Search [make ‘Dear OKeep @Best OSync [Test
Package Current New Bin? Src? Categories 5IZ+ "
libWMaker-devel 0.95.8-1 0.95.8-2 hd U Libs *
libWMaker1 0.95.81 0.95.8-2 hd D Libs Y
libpagemakertools 0031 0032 hd D Graphics Bk
libpagemaker(.0-debuginfo 0.0.31 0032 hd I:‘ Debug 591k
libpagemakerD.0-devel 0031 0032 hd D Libs 2
libpagemakerl.0-doc 0.031 0032 | D Libs 10%
libpagemaker0.0_0 0.0.31 0.0.32 | D Libs 65k
e % - ¥ N - (- B N 7T
make-debugirfo 4212 Keep ~| ] [] Debug 368K
makedepend 1051 Keep =[O0 [ e Wk
makedepend-debuginfo 1.051 Keep hd D D Debug [
< >
Hide obsolete packages
< Back Next > Cancel

Figure 19: Get cmake and make

o Clear the search bar. Search for gdb. You will see the following screen.

down box on the line for gdb. Choose a number like 8.1.1.

Click on the drop

[E cygwin Setup - Select Packages - [m} X
Select Packages
Select packages to install =
View ‘Full ~|  Search [gdb Clear OHKeep @Best OSmnc [JTest
| Package Cument New Bin? Src? Categories Size A
cadb 0.6.7+20170812+gitfad4cOa-1  0.6.7+20190803+gitb632611-1 = ] Devel 63%
cgdb-debuginfo 0671 Keep ~| [0 [ Debug 334k
oo [70011 81.1-1 Rl o2 | W loeve | 2395
gdb-debuginfo 7.10.141 8111 ~| [] Debug 23911k
adbm 11241 11811 ~| [] Database 161k
adbm-debuginfo 1124 11814 ~| [1 Debug 28%
libgdbm-devel 1121 1.18.1-1 ~| ] ubs 14
libgdbmé4 11241 1131 ~| [ ubs 20k
libgdbmé 11814 ~| [ ubs 2%
libgdbm_compat 1.18.11 | ] ubs &
mingwB4i686-gdbm 11241 Keep ~| [ Devel 56k v
< >
Hide obsolete packages
< Back ‘ Next > ‘ Cancel

Figure 20: Get gdb

e Clear the search bar. Then click Next. You will see the following screen where CygWin will
show you a list of dependencies. Just click Next. CygWin will now install the new packages

we have specified. This should not take too long, only about 10 minutes.
of the CygWin installation wizard, click Finish.

On the final screen



E cygwin Setup - Resolving Dependencies - O X

Resolving Dependencies
The following packages are required to satisfy dependencies. b

libboost_atomic1.64 (1.64.0-1) A
Boost C++ libraries
Required by: libboost-devel

libboost_chrono1.64 (1.64.0-1)
Boost C++ libraries
Required by: libboost-devel, libboost_timer1.64

libboost_containerl.64 (1.64.0-1)

Boost C++ libraries

Required by: libboost-devel v
< >

Select required packages (RECOMMENDED)

< Back Next > Cancel

Figure 21: Dependencies

e Back in CLion, the software will now try and detect the new libraries. After about a minutes,
it should have automatically detected all the libraries. Click OK.

& settings X
[a- Build, Execution, Deployment > Toolchains

* Appearance & Behavior | e cyonin
Appearance _

Menus and Toolbars Environment: Download.

> System Settings o Cygwin V| Cicygwin6d V[

File Colors =] “ Version: 2.9.0

Scopes & CMake: Bundled e
Notifications * Version: 3.9.6

Quick Lists. .

Path Variables

Keymap
> Editor Cs+ Compiler: | Detecting

C Compiler:

Plugins
> Version Control ® Debugger Use Cygwin GDB
 Build, Execution, Deployment “ Version: GNU gdb (GDB) (Cygwin 7.101-1) 7101

CMake

> Debugger
Python Debugger
Python Interpreter

> Deployment

8 a

> Console
> Languages & Frameworks
> Tools

° Conel

Figure 22: CLion detecting CygWin Libraries

CLion will now start up for the first time, and resolve all the external dependencies and
symbols. This takes about 5 minutes. You are now good to go.
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4 Creating a Project

In order to write and run a C++ program on CLion, you should first create a project. Open CLion
and then choose File ->New Project.

mgdlt View Navigate Code Refactor Run Tools VCS Window Help

Import Project...
NewscratchFile  Ctrl+Altsshiftinsert

= Open...
Open URL...
Open Recent

i (EProjecti -] b # | Q

close Project
% Settings... CtrlvAltss

Default settings...

Import Settings...

Export Settings...

‘Settings Repository...
& Reload CMake Project
K saveAll ctrlss.
i synchronize CerlsAlesy.

Invalidate Caches / Restart...
' Print...

Power Save Mode

Exit

[ Create anew CMake Project

Figure 23: Opening a New Project

You will now see a screen where it asks you to choose where to save the project. Also, the project
is called “untitled” by default. Change it to a name of your preference, and if requires, a location
that you can easily remember. By default, it is saved in a Folder called CLionProjects.

C#+y — i - - -
Location: |fhnme,fsharanya,fCLlnnPrnJects,fPrnJeth |B
A C++Library Language standard:

C
A CExecutable
A ClLibrary

Figure 24: New Project Name and Location

Click on Create. This will open a new project with a default program stub. This program is called
“main.cpp”. We will usually require to to give specific names to your programs. This requires you

to refactor the project. Right Click on “main.cpp” in the Project Explorer Window on the left and
choose Refactor ->Rename.
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Eile Edit View Navigate Code Refactor Run Tools VCs Window Help

Project2 ; ¢ main.cpp ) 4 (B Project2 -] B ¥ Q
7 Project @ % | #- 1| A cMakeLists.txt - | 2 main.cpp
Project2 ~/CLionProjects/Project2 1 #include <iostream> v
cmake-build-debug 1nt natn() 1
A“;':;k:;:“m 4 - std:scout << "Hello, Worldi® << stdiiendl;
il ExternalL  NeW e !
() Reload CMake Project
X% cut ctrlsx
[0 Copy cerl+C
Copy Path ctrlsshiftsc
CopyRelativePath  CtrlsAltsShiftsc
[l Paste ctrlsv
Find Usages Alt+F7
Inspect Code...
) T
Clean Python Compiled Files Chal ature. Ctrl+F6
‘Add to Favorites » Move... F6
Delete... Delete  COPY-- =
Local History » Safe Delete... Alt+Delete
@5 synchronize 'main.cpp’ Extract D
Show in Files [0 Al
File Path Ctrl+Albsshifts2
4 Compare With... ctri+p.

® CreateGist...

I Rename the selected symboland correct all references 62 LF: UTF8: Context:Project2[D] @ & ()

Figure 25: Renaming the file

In the following window, give the file its required name.

* Rename

Rename file 'main.cpp’ and its usages to:

[sample.cpp 1

Search in comments and strings

I Preview ‘ I Cancel | \ Help |

Figure 26: Renaming a file

Click on Refactor. You are now ready to start writing your program.

5 Running your program

Once you have completed writing your program, save your work by choosing File ->Save. Before
running your program, you have to Build your project. This compiles your program and if your
program is error free, it gets your program ready for execution. Choose Run ->Build. You should
see something like the following screen:

e B View Nvigte Sode Seraor A Took VS Mindow Lidp

b Bz > e w Q

vl braes

e
Bt Toraet Project

Ll 2 L

Figure 27: Building the Project
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The console window on the bottom of your screen will show you the Build results. If your program
has errors, they will be listed there. If the program compiles fine, it will say “100% Built Target”
followed by the Project name.

Once your project builds successfully, you can run it. Choose the project on the drop down list
in the top right corner and then click on the green arrow button next to it. Your output will be
displayed on the bottom of the screen in the console window.

File Edit View Navigate Code Refactor Run Tools VCS Window Help

Project2 ) c.. sample.cpp. Hi (B Projectz -] b ¢ Q
& Project @ & | #- 1| A CMakeLists.txt csample.cpp
Project2 ~/CLionProjects/Project2 #include <iostreams v
cmake-build-debug 2 it mainl B
. int main
4 abetitstnt std:icout << "Hello, World!" << std::endl;
i sample.cop 5 std::cout<<"This is an example"<<std::endl;
Il External Libraries return 0;
¥
Run & Project2 # L
S /home/sharanya/CLionProjects/Project2/cnake-build-debug/Project2
Hello, World! [N
This is an example
- 75| Process finished with exit code 0
]
P
<|®
?
1 Build finished in 52ms (moments ago) 72 LF: UTF8: Context:Project2[D] = & (1

Figure 28: Running the Project

6 Opening an Existing Project

To open an existing project choose File >Open. In the dialog box that pops up, navigate to the
location where you saved the project. Click on the project name and then click OK.

0 Open File or Project

AR, EX O 8 Hide path
home/sharanya/CLionProjects/Project?] [}
i anaconda2
Android

android-studio
AndroidStudioProjects
Applications
Caitlin
Classes
CLionProjects
= Project1

» [ Project2
Desktop
Documents
Downloads
HERC

L idea-1C-141.1532.4

Drag and drop a file into the space above to quickly locate it in the tree

m Cam:el‘ Help ‘

Figure 29: Running the Project

If you already have a project open, CLion will ask you if you would like to open this project in the
same window or in a new window. You can choose either option.
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7 Turning in your assignment

CLion would have created a folder where it places your projects by default. Alternatively, you
might have specified a folder to put your project in when you created it. Navigate to the folder on
Finder (Mac) or Folders (PC) and you will see a Folder for your Project. Opening that will show
you all the source files under that project. The .cpp file is the file you need to turn in through
Canvas

8 Troubleshooting

This section can be used for troubleshooting the most common errors you might encounter while
installing CLion. If your problem persists after trying this, please contact your instructor/ TA for
help.

8.1 On Windows

The most common issue on Windows is a glitch in the CygWin installation when a few critical
dependency files are not downloaded. Please go through the following steps:

1. Open CLion. Go to File ->Settings. Choose Build, Execution, Deployment. and then
choose Toolchains.

2. You will see “Download” link on the right. Click on the link.

3. Go through the steps for the CygWin installation again (the list below Figure 11), until you
see the packages screen. However, this time, choose a different mirror.

4. Go to the Drop-down box on the top left, that says “Pending” and choose “Full”.

5. Go through the process of installing the 7 libraries again, but this time, make sure you get
version numbers that are higher than the ones you have installed. Otherwise, go back and
choose a different mirror. Keep doing this until you see higher version numbers, and install
the latest versions.

6. Restart CLion. The old project would have been opened under the old settings. Open a new
project. You should now be able to run it without issues. The very first time you build a
project with CLion, it will take a little time to index all the libraries. Please wait until the
little arrow on the top right goes green before running.

8.2 On a Mac

CLion usually installs without trouble on a Mac. Some older versions of OSX might have issues
due to the different versions of the C++ compiler. OSX does not allow you to directly update the
Clang tools needed for this, but you can re-install the XCode developer tools, which will get all the
updates you need indirectly. Please go through the following steps.

1. Open the Terminal.

2. Re-install XCode developer tools by typing
xcode-select --install
and press Enter.
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3. Accept the XCode user license. On the terminal, type
sudo xcodebuild -license
Enter the admin password for the computer when prompted. Please not that you will not see
the password being typed in. This is ok. Type in the password and press Enter.

4. The license will then be presented on screen. Hit the space bar to scroll through the text.
When you get to the end of the text, you'll be prompted to enter “agree”. Type this in and
hit Enter.

5. Restart CLion, click on File ->Reload CMake Project and everything should work.
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